[COMPLETED]ssdsemi13 :: Unplanned Maintenance Tuesday 21st September 2021 10:14:25


Our System Operations team is initiating unplanned maintenance on ssdsemi13. Users hosted on this server may experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 3:18 PM EST: Our System Operations team has completed the maintenance and all services are back online.