[COMPLETED] Scheduled Maintenance - MI Data Center Thursday 12th August 2021 19:00:00


Start Date: Thursday, August 12, 2021

End Date: Friday, August 13, 2021

Time: 11:00 PM - 3:00 AM EST 

Services Affected:

Michigan Data Center

Description: Our System Operations team will be performing scheduled maintenance in our MI Datacenter. Users may experience a brief service interruption while the routine scheduled maintenance is performed

UPDATE 11:00PM EDT: Our Network Engineers are starting the maintenance as per schedule. We will keep you posted with the progress in this regard. Thank you for your patience in this matter.

UPDATE 2:30AM EDT: The maintenance is still not finished, updates will be provided when the maintenance is complete.

Update 3:40 AM EDT: The scheduled maintenance has been completed at this time. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.