[RESOLVED] Sectigo SSL Certificates :: Degraded Performance Monday 2nd August 2021 08:51:24


Sectigo is currently experiencing degraded performance with their issuing platforms. Users will experience delays with free SSL certificates being issued or renewed as a result. You can view Sectigo's status page at https://sectigo.status.io. We will provide further updates as they're made available.

UPDATE As of 2:20 PM EDT today this issue looks to be resolved by Sectigo, if you're still experiencing issues with Free SSL Certificates being issued, please inform us via ticket.