[RESOLVED] mi3-sr20 :: Service Interruption Friday 16th July 2021 01:52:46


mi3-sr20 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE: 05:53 AM EDT:: Our System Operations team resolved this matter and all services are operating as expected at this time.