[RESOLVED] Mailchannels Outbound Email Interruption Wednesday 14th July 2021 05:45:23


We are aware of multiple reports of issues with MailChannels our outbound Vendor for emails from our shared and reseller platform. Our team has reached out to MailChannels and is looking into it, updates will be posted here as further information becomes available.

UPDATE As of 11:31 AM :: MailChannels are working to rectify this. We will post updates as more information is made available in this regard. We sincerely appreciate your patience and understanding in this matter.

UPDATE 3:00 PM EDT: Issues with MailChannels have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.