[RESOLVED] Mailchannels Outbound Email Interruption Tuesday 13th July 2021 10:45:37


We are aware of multiple reports of issues with MailChannels our outbound Vendor for emails from our shared and reseller platform. Our team has reached out to MailChannels and is looking into it, updates will be posted here as further information becomes available.

UPDATE 5:00PM EDT: MailChannels has acknowledged the issue on their end and they are working to rectify this. We will post updates as more information is made available in this regard. We sincerely appreciate your patience and understanding in this matter.

UPDATE 6:00PM EDT: MailChannels are making progress and have stated that the emails backlog is reducing steadily. We will post an update as we receive more information in this regard

UPDATE 8:30PM EDT: Issues with MailChannels have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.