[RESOLVED] Client Area :: Service Interruption Thursday 1st July 2021 12:24:27


Client area at A2 Hosting is currently experiencing a service interruption. Users may experience features missing or not working normally. Our development team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 5:00PM EST: Client area issues have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.