[COMPLETED] a2ss4 :: Emergency Maintenance Friday 18th June 2021 18:58:11


a2ss4 is currently experiencing issues. Our System Operations team is initiating an emergency maintenance to identify and rectify the root cause of the issues. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 11:55PM EDT: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.