[RESOLVED] Multiple :: VPS Interruption Tuesday 8th June 2021 14:51:07


Some VPS hosted in our Michigan facility are currently experiencing a service interruption. Users hosted on affected servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:50PM EDT: Our Operations team staff are still working on this. We will post updates as more information becomes available. We apologize for the inconvenience faced in the meanwhile and sincerely appreciate your patience and understanding in this regard.

UPDATE 8:50PM EDT: Some VPSes are already back up, our team is working on the remainder of the affected VPSs.

UPDATE 9:25PM EDT: Issues on all impacted accounts have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.