[RESOLVED]A2 Hosting Phone System Tuesday 1st June 2021 05:47:01


Our engineers are currently investigating an issue with our Phone system, which is preventing customers calling in from connecting to one of our agents. We will continue to keep this post updated until the issue has been resolved. If you need to reach our support team, please use our Live Chat or open a ticket directly through https://my.a2hosting.com

 

UPDATE 10:21 AM EDT: Our Engineering team has resolved this matter and our phone service is available again at this time.