Start Date: Saturday, May 29, 2021
Start Date: Saturday, May 29, 2021
Time: 12:00 AM - 4:00 AM GMT+2 (Friday, May 28, 2021, 7:00 PM - 11:00 PM EDT)
Description: Our Network Engineering team will be performing scheduled maintenance in our Amsterdam datacenter. Users will experience brief service interruptions while the routine scheduled maintenance is performed.
Update 7:00PM EDT: Maintenance will begin shortly, updates will be provided when the maintenance is complete.
Update 8:02PM EDT: We have completed the maintenance.