[RESOLVED] a2ss31 :: Service Interruption Tuesday 25th May 2021 18:37:09


a2ss31 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:04 PM EDT: Issues on a2ss31 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.