[RESOLVED]sgssdsemi3 :: Emergency Maintenance Saturday 22nd May 2021 21:59:20


To ensure stability and quality of service, our team is having to perform some emergency maintenance onĀ sgssdsemi3. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available. We sincerely apologize for the inconvenience in the meanwhile.

UPDATE 2:25AM ET: We have completed the maintenance and all services should be operating as usual. Please contact support if you run into any issues.