[COMPLETED] Singapore DC Maintenance Wednesday 5th May 2021 06:02:48


Scheduled Maintenance - Singapore Data Center

Maintenance Window from May 6, 2021, 12:00 AM - 6:00 AM GMT+8  (May 5, 2021, 12:00 PM - 4:00 PM EDT)

Services Affected: Singapore Data Center

Description: Our Network Engineering team will be performing scheduled maintenance in the Data Center. Users may experience brief service interruptions while the maintenance is performed.

UPDATE: 4:00PM EDT (4:00 AM Singapore): Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.