[RESOLVED] Intermittent Connectivity Issues Thursday 29th April 2021 14:14:21


Our System Operations team is currently aware of reports of intermittent website & email connectivity issues affecting a subset of customers in our Michigan data center. We are working on this and will provide updates as more details are made available. We sincerely apologize for the inconvenience and appreciate your patience and understanding in this matter.

UPDATE 9:50 AM EDT ::  We are still receiving some reports of slowness or intermittent connectivity troubles in the data center. They are continuing to work toward a resolution.

UPDATE 1:30 PM EDT ::  Our Engineers have resolved the issue that was causing intermittent connectivity issues for some of our customers.  If you are still experiencing connectivity issues or timeouts please reach out to our support team to address.