[RESOLVED]mi3-sr6 :: Service Interruption Friday 16th April 2021 09:28:06


mi3-sr6 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 1:56 PM EDT: Our System Operations team has resolved this issue and all services are back online at this time.