[RESOLVED]Amsterdam Data Center :: Connectivity Issues Friday 26th March 2021 01:32:22


Our Engineering Team is investigating reports of intermittent connectivity issues to our Amsterdam Data Center. We will update you with the progress on this issue.

UPDATE 6:10 AM EST: Our Engineering team confirmed we are no longer seeing reports of connectivity issues to our Amsterdam data center. If you continue to experience issues please contact our Technical Support team directly.