[RESOLVED]mi3-lr8 :: Service Interruption Thursday 11th March 2021 09:46:07


mi3-lr8.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 3:05 PM EST: Our Systems Operations team has corrected the issue and all services should be back online at this time.