[RESOLVED] mi3-tr1 :: Service Interruption Wednesday 10th March 2021 18:35:03


mi3-tr1 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 12:15 AM EST: Our Systems Operations team has corrected the issue and all services should be back online at this time.