Amsterdam Data Center :: Scheduled maintenance :: Tuesday 9th March 2021 13:00:00


Start Date: Wednesday, March 10, 2021 (03/09/21 EST)

End Date: Wednesday, March 10, 2021 (03/09/21 EST)

Time: 1-2 AM CEST  (7-8 PM EST)

Services Affected:

Amsterdam Data Center

Description: Our System Operations team will be performing a scheduled maintenance in the Data Center. Users may experience brief service interruptions while the maintenance is performed.

Updated 7:00 PM EST: The maintenance at the Amsterdam Data Center has begun.

Update 8:00PM EST: The maintenance at the Amsterdam Data Center has been completed. Please reach out to our support team should you have encounter any issues.