[RESOLVED] Singapore Data Center Connection issues Sunday 7th March 2021 07:15:00


We are currently investigating a network connectivity issue in our Singapore datacenter. Our Operations and Engineering teams are aware of this issue and working diligently to rectify the situation. Further updates will be provided as they become available.

Update 12:45PM EST: ::Our Engineers are continuing their investigation into the root cause of this issue. Some services may still be unavailable during their investigation. We will provide additional updates as they are received.

Update 1:25PM EST:: Our Engineers are still working on addressing the issue and returning the connectivity to normal. We appreciate your continued patience.

UPDATE 2:49 PM EST: Our System Operations team has now confirmed this issue is resolved, please reach out to us if you are still seeing any issue.