[RESOLVED]mi3-ts7 :: Service Interruption Friday 26th February 2021 09:00:00


mi3-ts7.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 2:19 PM EST: Our System Operations team has fixed this issue and all services are back online.