[RESOLVED] Amsterdam Data Center :: Connectivity Issue Wednesday 24th February 2021 23:36:45


Our Operations/Engineering Department is looking into connectivity issues to our Amsterdam Data Center. We will update you with the progress on this issue.

We appreciate your patience in this matter.

[RESOLVED] 2/25/2021 4:40 EST - Our engineering department has corrected this issue and restored connectivity.