Amsterdam Data Center :: Scheduled maintenance :: Wednesday 24th February 2021 10:50:00


Start Date: Wednesday, February 24, 2021

End Date: Wednesday, February 24, 2021

Time: 1-4 AM CEST  (6-9 PM EST)

Services Affected:

Amsterdam Data Center

Description: Our upstream provider will be performing scheduled maintenance in the Data Center. Users may experience brief service interruptions while the maintenance is performed.

Update: The Maintenance has begun in our Amsterdam Data Center

Update 3:28 AM CEST (8:28PM EST): The Maintenance has been completed in our Amsterdam Data Center. Please reach out to our support team should you encounter any issues.