[RESOLVED] Support Mail :: Service Interruption Thursday 28th January 2021 15:26:09


Our Helpdesk email is experiencing a service interruption. Any emails sent to support currently will be delayed. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. In the meanwhile, please update tickets directly from client area at https://my.a2hosting.com/ or reach out to our live chat and phone support directly.

UPDATE 9:20PM EST: Issues with email have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.