[COMPLETED] Amsterdam DC :: Scheduled Maintenance Wednesday 20th January 2021 11:10:48


Start Date: Wednesday, Jan 20th 2021

End Date: Wednesday, Jan 20th 2021

Time: 5:00 PM - 5:30 PM EST

Services Affected: Our Engineering team will be performing scheduled maintenance in our Amsterdam datacenter. Some users may experience multiple momentary network interruptions while the routine scheduled maintenance is performed. We will keep this thread posted with the latest status updates.

UPDATE 5:01 PM EST: The maintenance has started in our Amsterdam datacenter.

UPDATE 6:05PM EST: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.