[RESOLVED] a2ss11 :: Service Interruption Wednesday 13th January 2021 00:36:29


a2ss11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 6:04 AM EST: We are glad to report that a2ss11 is back online. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.