Michigan DC :: Scheduled Maintenance Wednesday 13th January 2021 05:00:00


Start Date: Wednesday, Jan 13th 2021

End Date: Thursday, Jan 14th 2021

Time: 10:00 PM - 1:00 AM EST

Services Affected: Our System Operations team will be performing routine scheduled maintenance in our Michigan datacenter. Users may experience multiple momentary network interruptions while the routine scheduled maintenance is performed. 

UPDATE 10:00PM EST: Our Engineering team has started the maintenance. We will post updates as more information becomes available.

UPDATE 11:15PM EST: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.