NL DC :: Scheduled Maintenance Saturday 9th January 2021 14:00:00


Start Date: Sunday, January 10, 2021

End Date: Sunday, January 10, 2021

Time: 1:00 AM - 4:00 AM CET (Sunday, January 9, 2021, 7:00 PM - 10:00 PM EST)

Services Affected: Our System Operations team will be performing routine scheduled maintenance in our Netherlands datacenter. Users may experience multiple momentary network interruptions while the routine scheduled maintenance is performed.

UPDATE 7:03PM EST: The maintenance has now started.

UPDATE 10:30PM EST: The maintenance has extended past its normally scheduled time frame. We will provide additional information as it becomes available. 

UPDATE 11:30PM EST: The maintenance at our Netherlands datacenter has been completed. Please reach out to our support team and let us know if you run into any additional issues.