a2ss35 :: Service Interruption Sunday 8th April 2018 13:44:00


A2SS35 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 7:04PM Eastern: Some functionality has been restored but service degradation is still expected for some users. We continue to work on the issue and will continue to post updates as they occur.

Update 7:15PM Eastern: Service has been restored and are operational. Thank you.