Arizona DC :: Connectivity Issues Sunday 22nd November 2020 21:25:31


Our Arizona data center is currently experiencing connectivity issues. Users hosted in this data center will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 2:50AM EST Our engineers found the issue and are working on fixing it. Most services should be available again, we continue monitoring this situation with our Arizona data center for any re-occurring issues.

Update 3:10AM EST All servers are currently back up and responding fine. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.

Update 3:45AM EST It has come to our attention that there is still a network problem in Arizona DC. Our System Operations team is still working on this issue. Further updates will be provided as they become available. 

Update 4:45AM EST: The connectivity issue affecting the data center should now be resolved. Please reach out to our support team should you encounter any further issues.