[RESOLVED] Phone Support Interruption Thursday 19th November 2020 10:57:47


Our phone system is currently experiencing a service interruption. Please use our Live Chat or open a ticket while our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 4:10PM EST: Issues with phones have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live chat or ticket support for assistance.