Netherlands DC :: Connectivity Issues Saturday 7th November 2020 16:35:00


Our Systems Operations team is currently aware of connectivity issue affecting the Netherlands data center. Users hosted in this data center will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 10:45 PM EDT: Our System Operations team is still working on this issue. Further updates will be provided as they become available.

UPDATE 11:44 PM EDT: The connectivity issue affecting the data center should now be resolved. Please reach out to our support team should you encounter any further issues.