[RESOLVED]mi3-sr4.supercp.com Tuesday 29th September 2020 09:23:12


mi3-sr4.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 1:30 PM EDT: Our System Operations team was able to resolve the issue affecting mi3-sr4.supercp.com. All services have been restored and are available at this time.