[RESOLVED]mi3-ss52 :: Service Interruption Saturday 19th September 2020 20:35:00


Update 1:20AM EDT: Our System Operations and Engineers are currently working to resolve the issue affecting this server. Further updates will be provided as they become available.

Update 3:00AM EDT: Our System Operations and Engineers continue to work on resolving the issue affecting mi3-ss52.a2hosting.com. We will provide updates as more details are made available.

Update 4:45AM EDT: Our System Operations and Engineers were able to resolve the issue affecting mi3-ss52.a2hosting.com. The service is available once again.