[RESOLVED]Arizona DC :: Connectivity Issues Saturday 22nd August 2020 22:18:52


Our Arizona data center is currently experiencing connectivity issues. Users hosted in this data center will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 2:35AM EDT: All servers are currently back up and responding fine. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.