[RESOLVED] Arizona Servers :: Investigating Wednesday 19th August 2020 22:34:36


We are currently experiencing issues with servers in our Arizona Data Center. Operations is investigating the issue and we will update the status as soon as more information is available.

RESOLVED: The issue was out of our network. L3 (Century Link) was having issues, and their engineers found the problem and it is resolving itself.