A2S66 A2S67 A2S68 A2S69 SR6 :: Service Interr Friday 23rd March 2018 17:32:01


A2S66, A2S67, A2S68, A2S69, and SR6 currently experiencing service interruptions. Users hosted on these servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:25 PM EDT: A2S68 and A2S69 are back online. Engineers are working to restore service to the remaining servers.

Update 2:25 AM EDT: A2S66 and SR6 are back online. Engineers are working to restore service to A2S67

Update 3:30 AM EDT: A2S67 is back online. All services are available once again.