[RESOLVED] Client Portal :: Service Interruption Saturday 8th August 2020 18:50:00


The client portal is currently experiencing service interruptions. Users attempting to login will experience service degradation as a result. Our System Operations team is currently investigating the root cause of this interruption. We will provide updates as more information becomes available.

UPDATE 10:53 PM EST: The client portal should now be back up and running. Please reach out to the support team should you experience any further issues.