[RESOLVED] MI3-WTS4 :: Service Interruption Thursday 22nd March 2018 17:51:30


MI3-WTS4 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE: As of 22:00 EDT MI3-WTS4 is back online.