[COMPLETED] mi3-ts2 :: Scheduled Maintenance Tuesday 21st July 2020 09:00:00


Start Date: Tuesday, July 21, 2020

End Date: Tuesday, July 21, 2020

Time: 1:00 PM- 2:00 PM EST

Services Affected:

mi3-ts2.a2hosting.com

Description: Our System Operations team will be performing scheduled maintenance on the server. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 2:09 PM EST: Maintenance has been completed on the server. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.