[RESOLVED]mi3-wtr2 :: Service Interruption Monday 6th July 2020 04:31:30


mi3-wtr2.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 8:45 AM EST: Our System Operations team has resolved this matter and all services are online at this time.