[COMPLETED] mi3-wts9 :: Maintenanace Wednesday 24th June 2020 19:08:18


mi3-wts9 is currently experiencing issues that require a reboot. Our Operations team is going to reboot the server shortly to correct the issues. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 11:20PM EDT: Maintenance has been completed on mi3-wts9. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.