[RESOLVED]DNS :: Service Interruption Monday 15th June 2020 02:04:26


Our Engineering team is investigating the root cause of an intermittent interruption of DNS services. We will provide updates as more details are made available.

UPDATE 9:05 AM EST: Our Engineering team is working with our vendors on this issue. We will continue to provide updates as they're made available.

UPDATE 10:35 AM EST: Our Engineering team worked with our vendors to resolve this issue. Our Engineering team will continue to monitor services closely.

UPDATE: Issues with DNS have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.