[COMPLETED] mi3-wts7 :: Scheduled Maintenance Saturday 30th May 2020 16:09:00


Start Date: Sunday, May 30, 2020

End Date: Sunday, May 30, 2020

Time: 10:00 PM - 11:59 PM EST

Services Affected:

mi3-wts7.a2hosting.com

Description: Our System Operations team will be performing maintenance on the server. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE: 10:30PM EST: The scheduled maintenance has been completed.