[RESOLVED]mi3-wts10 :: Reboot Required Friday 1st May 2020 05:52:11


mi3-wts10.a2hosting.com is currently being rebooted to correct an issue on the server. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 10:00 AM EST: Our System Operations team has performed the reboot and all services are back online.