[COMPLETED]Michigan Datacenter :: Scheduled Maintenance Sunday 3rd May 2020 08:00:00


Start Date: Sunday, May 3, 2020

End Date: Sunday, May 3, 2020

Time: 12:00 AM - 4:00 AM EDT

Service Affected: Michigan Datacenter

Description: Our System Operations team will be performing routine scheduled maintenance that will impact all of our services in our Michigan Datacenter. Customers may experience a very brief service interruption while the maintenance is performed.

Update 12:05AM : The maintenance is being performed at this time.

Update 3:05AM: The maintenance was completed at this time.