[RESOLVED]mi3-wss11 :: Service Interruption Sunday 22nd March 2020 23:24:52


mi3-wss11 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 3:36AM: Our Operations team was able to correct the cause of the service interruption. The server is once again available.