mi3-ss8 :: Scheduled Maintenance Thursday 19th March 2020 05:24:51


Start Date: Friday, March 20, 2020

End Date: Friday, March 20, 2020

Time: 1:00 AM - 2:00 AM EST (12:00 AM - 1:00 AM UTC)

Services Affected:

mi3-ss8.a2hosting.com

Description: Our System Operations team will be performing routine emergency maintenance. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 2:40 AM EDT: Our System Operations Team has started working on this. We will post updates as more information is made available.

UPDATE 2:50 AM EDT:  This maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.