[RESOLVED]mi3-ss30 :: Service Interruption Saturday 14th March 2020 22:05:49


mi3-ss30 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 2:20AM: The server is once again online and available, as our System Operations team was able to correct the issue. We'll continue to monitor the server for any further issues.